File Times bad after copying to device

Oct 25, 2010 at 2:38 PM


I'm using CopyFileToDevice() in the RAPI class.  After the copy is compete the Modified time on the file is 4 hours earlier than it should be.  I'm in the U.S. Eastern time zone (GMT -4) so I'm presuming that there is a problem with adjusting the time relative to GMT after the copy has completed.  I've also tried using SetDeviceFileTime() and get the same result.

I did find some info from back on 5/3/04 when version 2.8 was released that leads me to think that this problem was addressed in that version.

We've released version 2.8 of the OpenNETCF.Desktop.Communication library.

New in this build:
- Fixed bug in SetDeviceFileTime
- CopyFileToDevice now keeps device date/time info same as PC date/time
- Fixed bug in CopyFileFromDevice for disconnect during copy conditions
- Added CreateDeviceShortcut and CeSHCreateShortcut P/Invoke
- Added GetDeviceShortcutTarget and CeSHGetShortcutTarget P/InvokeThe code that

I'm using the latest 45072 patch.  Is it possible that this problem could have crept back into the code?  Any help would be greatly appreciated.

Thank you

Tim Sheppard