XP64 Can't find Rapi.dll

Jan 14, 2010 at 9:55 PM

I have it working perfectly on XP and vista 32 bit. When i try to use it on XP 64 bit. When I declare a instance of Rapi.cs I instantly get the error about not being able to find the Rapi.dll. I fiqure it is because it is looking in Windows\System32 and ActiveSync4.5 installed it in System\SysWow64. I tried copying it to the System32 folder then it claims it can't load it because it is in the improper format. I also tried copying the dll from a 32bit system and get the same error about the improper format. I'm using the latest patch version of (27109). I'm new to using this library and any help will be appreciated.

Jan 15, 2010 at 2:54 PM

Do give you more information:

1. When the rapi constructor gets called it calls the ActiveSync Contructor. The ActiveSync Contructor then calls the DccMan constructor. the DccMan constructor is where the error is comming from.

2. This is the error: Unable to load DLL 'rapi.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E). I checked the registry for the Guid("499C0C20-A766-11cf-8011-00A0C90A8F78") and its ImProcServer key is pointing to the right directory.

3. When I try putting the rapi.dll in the system32 directory I get the fol1owing error: An attempt was made to load a program with an incorrect format. (Exception from HRESULT: 0x8007000B). It doesn't matter if I use a 64 bit version to put inthe Windows\System32 directoryor a 32 bit version I get the same error.

Jul 27, 2010 at 3:45 PM

i am also getting same problem in XP64 bit with latest build.....of OPENNETCF

can you please help....how to solve this problem...

Jul 29, 2010 at 8:19 AM
Edited Jul 29, 2010 at 8:19 AM

Do you use the latest change set (45072)?


Jul 29, 2010 at 10:21 AM
Edited Jul 29, 2010 at 10:21 AM

Now i got it working....just changed the taget build option to x86 then it worked....in XP 64 bit...